Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

YITH WooCommerce Quick View

This plugin adds the possibility to have a quick preview of the products right from product list

Sometimes the halfway is better: what if you are looking to a product in a list and its image is still too small?

You have to open its product page, waiting for its loading and finally observe what you are interested into. So why don't use a simple way to look immediately at the product's distinctiveness? Here it is what Quick View can offer you.

People are more attracted to what they can see clearly. And often the classic product lists are not enough to understand the real value of a product. That's when Quick View strikes successfully! Your clients will be free to look in a better way your products, reading also a small description with all the most important features and qualities you want to underline. In this way, they will be more focused on what they really want and they will proceed easily to the purchase step.

Main features:

  • Add a button in product loop to open a modal window with the product summary using ajax
  • Choose to enable the prettyPhoto lightbox for images in quick view
  • Customize style of modal

Full documentation is available here.

Contributors yithemes
Tags free quick view, modal, product summary, products quick view, quick-view, single product, summary, woocommerce, woocommerce extension, WooCommerce Plugin, WooCommerce Quick View, yit, yith
  1. yith-woocommerce-quick-view screenshot 1

    The plugin admin page.

  2. yith-woocommerce-quick-view screenshot 2

    The quick view button in shop page.

  3. yith-woocommerce-quick-view screenshot 3

    The quick view modal.

  1. Unzip the downloaded zip file.
  2. Upload the plugin folder into the wp-content/plugins/ directory of your WordPress site.
  3. Activate YITH WooCommerce Quick View from Plugins page.


Released Oct 24 - 2016

  • Fixed: Status code 404 for "Quick View" on single product page


Released Oct 20 - 2016

  • Added: Support to WooCommerce 2.6.5
  • Added: Support to WordPress 4.6.1
  • Fixed: Responsive style.
  • Fixed: Add inline css using WordPress function wp_add_inline_style.
  • Updated: Plugin Core.


Released Jun 10 - 2016

  • Added: Added minimized js files. Plugin loads full files version if the constant "SCRIPT_DEBUG" is defined and is true.
  • Added: Support to WooCommerce 2.6 RC1
  • Updated: Plugin Core


Released Apr 18 - 2016

  • Added: Compatibility with WordPress 4.5
  • Updated: Plugin Core


Released Oct 30 - 2015

  • Added: Compatibility with YITH WooCommerce Wishlist
  • Added: Compatibility with YITH WooCommerce Badge Management
  • Added: Italian Language
  • Updated: Language file .pot. Changed textdomain to yith-wcqv to yith-woocommerce-quick-view
  • Updated: Plugin Core


Released Aug 24 - 2015

  • Fixed: Main template issue


Released Aug 21 - 2015

  • Added: Compatibility with Wordpress 4.3
  • Added: WPML config xml
  • Fixed: Default variation select
  • Updated: Language file .pot


Released Aug 12 - 2015

  • Updated: Plugin Core


Released Aug 11 - 2015

  • Added: Compatibility with WooCommerce 2.4
  • Updated: Plugin Core
  • Updated: Language file


Released May 18 - 2015

  • Added option for enable quick view also in mobile device
  • Compatibility with Wordpress 4.2.2
  • Minor bug fix
  • Updated Plugin Core
  • Updated Language file


Released Mar 11 - 2015

  • Minor bug fix
  • Updated Plugin Core


Released Mar 06 - 2015

  • Added: Action yith_quick_view_custom_style_scripts
  • Added: Filter 'yith_quick_view_loader_gif


Released Feb 26 - 2015

  • Minor bug fix


Released Feb 17 - 2015

  • Initial release


If you have suggestions about how to improve YITH WooCommerce Quick View, you can write us so we can bundle them into YITH WooCommerce Quick View.


Available Languages

  • English

If you have created your own language pack, or have an update for an existing one, you can send gettext PO and MO file use so we can bundle it into YITH WooCommerce Quick View languages.

Version 1.1.4

Requires WordPress version: 4.0 or higher

Compatible up to: 4.6.3

Last Updated 24 Oct 2016

Date Added: 17 Feb 2015

Plugin Homepage


4.1 stars
14 ratings


Not Enough Data

Works: 0
Broken: 0