Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository


Screen Reader plugin free version for Wordpress is an advanced and lightweight plugin that will add an accessibility feature for reading contents.

Make your site ACCESSIBLE NOW with a text to speech plugin! Install this plugin and meet WCAG requirements in a few clicks! A MUST for every accessible site! It will add accessibility features to your website such as a text to speech engine to be compliant with WCAG specifications. Accessibility is mostly important for every modern website. Get it now for Wordpress and Joomla at The free version is limited to read only 100 characters and has only few features. The full version includes up to 3 high contrast rendering, the Dyslexic Font transformation and accessibility improvements such as focused elements outline, links target fix and more. It can be a precious tool even to be used as a reader for your page text working as a text to speech. The audio reader is able to read text in a lot of languages, up to 51 languages! You can take your eyes off and listen to the text thanks to this reader. Visit our website at to get the full and unlimited version of the plugin including the High Contrast feature.

Author JExtensions Store
Contributors JohnDagelmore
Tags accessibility, audio, font size, high contrast, screen reader, screenreader, WCAG

Upload the ScreenReader plugin to your blog, Activate it, and you'll see a bottom fixed bar on the frontend site You can configure details settings for your plugin in admin area, see manual for more informations. NOTICE: if you are upgrading from the free version to the full paid version ensure to uninstall completely the free plugin before installing the paid one.

The full paid version of the plugin must be installed using: 'Plugins'->'Add New'->'Upload plugin'->Choose file and click 'Install now'


  • First stable release for Wordpress

3.8 Full version

  • Added the Dyslexic font transform button
  • Added the slide expand/collapse for the toolbar
  • Fixed issue with Virtual Speaker audio engine to support PHP fopen disabled


  • Added the independent mobile audio engine option
  • Added the accessibility improvements feature
Version 3.7

Requires WordPress version: 3.0 or higher

Compatible up to: 4.6.3

Last Updated 08 Dec 2016

Date Added: 26 Jan 2016

Plugin Homepage


5 stars
1 ratings


Not Enough Data

Works: 0
Broken: 0