Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Require Post Category

Require users to choose a post category before saving a draft, updating a post, or publishing a post.

Tired of uncategorized posts? Use this simple plugin to require users to choose a post category before saving a draft, updating a post, or publishing a post. This applies to normal posts and is not compatible with custom write panels or custom post types without modification.

Translators

If you have created your own language pack, or have an update of an existing one, you can send the PO and MO files to me so that I can bundle it into the plugin. Download the latest POT file.

Author Josh Hartman
Profile
Contributors joshhartman
Tags admin, category, draft, force, Post, publish, require
  1. require-post-category screenshot 1

    Alert appears when you try to save a post without choosing a category

  1. Extract the require-post-category folder to your wp-content/plugins directory
  2. Activate the plugin through the admin interface

1.0.5

  • Added Polish (pl_PL) translation by Michał P.

1.0.4

  • Added Spanish (es_ES) translation by Andrew K.

1.0.3

  • Added i18n support

1.0.2

  • Updated for WordPress 3.6

1.0.1

  • FIXED: Disabled script when adding/editing pages

1.0

  • First stable release

Are there any settings I can adjust?

Nope, just install and activate, that's it!

Have a question that is not addressed here?

Leave a comment on the plugin homepage http://www.warpconduit.net/wordpress-plugins/require-post-category/

Share  
Download
Version 1.0.5

Requires WordPress version: 3.0 or higher

Compatible up to: 4.7.2

Last Updated 13 Feb 2017

Date Added: 14 Feb 2011

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

4.7 stars
3 ratings
5,383 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0