Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Pixeline's Email Protector

Write email addresses without worrying about spambots and email harvesters.

This plugin provides an unobtrusive yet efficient protection against email harvesters / spambots. Here is a demo.

Post/page authors may write email addresses in their article in the usual format ("john@doe.com") without exposing them to spam email harvesters. The plugin takes care of the obfuscation, implementing a graceful degradation technique focusing on usability so as to protect your email addresses from harvesters while keeping them usable to your human visitors.

The plugin replaces any email address found in posts, pages, comments and excerpts, and replace them by a bit of html markup that should deceive most email harvesters: <span class="email">john(replace the parenthesis by @)doe.com</span>. If javascript is available, it will display a clickable link and display the original email to the human user. Maximum usability, maximum protection.

Please rate the plugin if you like it.

Author pixeline
Profile
Contributors pixeline
Tags address, antispam, email, email protection, emailaddress, encode, encrypt, harvest, link, mailto, obfuscate, protect, protection, spam, spambot
  1. Unzip the file into your wp-content/plugins directory.
  2. In your wp-admin screen, activate the plugin. That's it, your emails are now safe!

Additionally, there is a Settings screen (Email Protector) allowing you you to customize the text that is displayed as a replacement to the email address.

1.3.6

mild fixes.

1.3.3

  • fixed admin ui

1.3.2

  • Support for WP 4.7

1.3.1

  • improved readme with a Demo + transition to Github + French translation.

1.3.0

  • Extensive rewrite.
  • Plugin does not run in the Admin anymore.
  • The plugin does not need jQuery anymore. Plain vanilla javascript.

1.2.6

1.2.5

  • Stupid error fixed. My bad.

1.2.4

  • Fixed all notices showing up when WP_DEBUG is true.

1.2.3

  • Fixed a possible cause of javascript errors on some setups.

1.2.2

  • Fixed Warnings appearing before comments.

1.2.1

  • Added filters for get_the_content, get_the_title and get_the_excerpt

1.2

  • Full code rewrite in OOP to avoid polluting the namespace.
  • added filters to protect emails in title, widgets, and comments.
  • Provided a function safe_email($email) to protect emails outside the loop in a theme for example.
  • Clarified the Settings screen and provided thorough documentation.

v1.1

  • Now detects "mailto:" links and protects them too.

v1.0.3

  • Added the option to specify what should be the visible part of the clickable email by adding a title attribute to the generated Anchor.
  • Changed the span class from "email" to "pep-email" to (kind of) use the "pep" namespace.

v1.0.2

  • Corrected the plugin's "Stable version" variable.
  • fixed folderpath issue because of the wrong foldername the wordpress repository generates for the plugin :-/

v.1.0.0

  • Initial release

Usage

Write your email addresses inside your posts and pages as usual. When the plugin is activated, it will replace them by a human-readable html string that explains how to deduce the email address, and if javascript is available (99.9% of the time), the original email address will be displayed as a clickable mailto: link. For example:

Hello john@doe.com. How are you today?

will become

<span class="pep-email">John( replace these parenthesis by @ )doe.com</span>

.

Additionally, you can specify what the mailto: link should look like by sticking a parenthesis inside of which you put the visible link text, like this:

Hello john@doe.com(John Doe). How are you today?

will become

<span class="pep-email" title="John Doe">John( replace these parenthesis by @ )doe.com</span>

.

inside a theme

If you need to protect emails inside your Theme's files (like the footer.php for example), you can use the function safe_email() like this:

echo safe_email('you@domain.com');

Contribute

Github repo: https://github.com/pixeline/pixeline-email-protector

Share  
Download
Version 1.3.6

Requires WordPress version: 2.7 or higher

Compatible up to: 4.7.2

Last Updated 06 Jan 2017

Date Added: 23 Jan 2010

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

4 stars
5 ratings
10,607 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0