Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

PaymentSpring Gravity Forms Add-On

Secure credit card processing with PaymentSpring beautifully integrated into Wordpress and Gravity Forms

PaymentSpring is a credit card processing gateway with a developer friendly API. This plugin is officially supported by PaymentSpring and will allow you to send credit card data in a secure manner from a Gravity Forms form.

This plugin will not work if Gravity Forms is not installed. You will need to purchase your own gravity forms license.

PaymentSpring API keys are required. You can obtain your own by registering for a free PaymentSpring test account.

Author PaymentSpring
Profile
Contributors rjwilson, jesseangell
Tags authorize.net, credit card, credit cards, gravity, gravity form, gravity forms, online payment, online payments, payment, payments, paymentspring, paypal
  1. paymentspring-gravity-forms-add-on screenshot 1

    Settings page

  2. paymentspring-gravity-forms-add-on screenshot 2

    Form configuration

  3. paymentspring-gravity-forms-add-on screenshot 3

    Form on webpage

  1. Make sure that Gravity Forms is installed and activated
  2. Upload the paymentspring-gravity-forms folder to the /wp-content/plugins/ directory
  3. Activate the plugin through the 'Plugins' menu in WordPress.
  4. Add your PaymentSpring API keys to the PaymentSpring section on the Settings page (Forms->Settings).
  5. Create a form, add the 'Credit Card' field that appears under 'Pricing Fields.'
  6. Click the downwards pointing arrow inside that Credit Card field. Select 'Use With PaymentSpring'
  7. Inside the above credit card field map the amount field to a field that represents the amount you want to charge.
  8. Inside the above credit card field, under the advanced tab, select Force SSL.

1.0.0

  • Initial release

1.0.1

  • Update to form conditionals

How do I get support?

This plugin is officially supported by PaymentSpring. If you're having a problem send us an e-mail at support@paymentspring.com

Do I need to have SSL?

Yes, we require any page that has a credit card field be encrypted by SSL

Share  
Download
Version 1.0.1

Requires WordPress version: 3.6 or higher

Compatible up to: 3.8.18

Last Updated 26 Oct 2016

Date Added: 13 Jun 2014

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

0 stars
0 ratings
428 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0