Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

NLB Payment Gateway For Woocommerce

Implements the Tebank payment gateway.

Requires: WooCommerce 2.1+

This plugin allows your store to make payments via NLB payment service.

If the transaction is successful the order status will be changed to "processing". If the payment charge failed the order status will be changed to "cancelled". If something is wrong with the connection between your server and the NLB server the order status will be changed to "on-hold". After successful transaction the customer is redirected to the default WP thank you page.

Author Mitko Kockovski
Profile
Contributors m1tk00
Tags gateway, manual payment, payment gateway, woocommerce
  1. Be sure you're running WooCommerce 2.1+ in your shop.
  2. You can: (1) upload the entire wc-gateway-tebank folder to the /wp-content/plugins/ directory, (2) upload the .zip file with the plugin under Plugins > Add New > Upload
  3. Activate the plugin through the Plugins menu in WordPress
  4. Go to WooCommerce > Settings > Checkout and select "NLB Payment Gateway" to configure.
  5. Make sure you fill in all NLB required fields.
  6. Upload the resourse.cng file from the settings section. The requested information can be found under the NLB console.
  7. Make sure you add the terminal alias.
  8. Make sure you select the currency.
  9. Make sure you select the language.
  10. Select your needed transaction type.
  11. Select your Error URL. This is the page that the customers will be redirected to after unsuccessful transaction.

2017.02.08 - version 1.1.2

  • Add payment complete action

2017.02.08 - version 1.1.0

  • Fix plugin domain
  • Small fixes

2017.01.24 - version 1.0.0

  • Initial Release

What is the text domain for translations? The text domain is nlb-payment-gateway-for-woocommerce.

What is the Instructions field? This field adds extra content to the thank you page, and the successful transaction tank you page.

Share  
Download
Version 1.1.0

Requires WordPress version: 3.8 or higher

Compatible up to: 4.7.2

Last Updated 08 Feb 2017

Date Added: 04 Feb 2017

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

5 stars
2 ratings
45 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0