Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

MailMojo Widget

Adds a signup widget for a MailMojo mailing list to your WordPress site.

This plugin requires a MailMojo account. MailMojo is a Norwegian email marketing webapp.
Get in on the mojo: Sign up for a free account here.

This plugin provides a super easy way for your visitors to sign up to your MailMojo mailing list. You can add multiple instances of the widget to accept signups to different lists, and tags are supported for segmentation.

You are welcome to contribute to this plugin on Github.

Author Eliksir AS
Profile
Contributors stianpr, asteinlein, fdanielsen
Tags email, email marketing, mailing list, mailmojo, newsletter, newsletters, signup, subscribe, widget
  1. mailmojo-widget screenshot 1

    The signup form in your sidebar.

  2. mailmojo-widget screenshot 2

    Customize the widget with your choices.

This plugin requires the PHP curl extension.

  1. Upload the widget directory to /wp-content/plugins/
  2. Activate the plugin through the "Plugins" menu in the WordPress admin
  3. Enter settings for the plugin at the "Settings > MailMojo" page
  4. Drag the widget to your desired location at the "Appearance > Widgets" page
  5. Specify the mailing list in your account, and customize any settings you want
  6. Receive signups, wheee!

1.0.3

  • Fix syntax errors in PHP 5.4.

1.0.2

  • Sort email lists in widget dropdown
  • Validate access token when updating settings

1.0.1

  • Fix syntax errors in PHP 5.4.

1.0.0

  • Important: Requires PHP 5.4 or newer.
  • Use MailMojo API to support retrieval of email lists.
  • Support single vs multiple tag selection.
  • Support fixed tags.

0.7

  • Prevent spam registrations by leveraging MailMojo's subscription endpoint with reCAPTCHA.

0.6

  • Support WordPress not being hosted on root of domain
  • Use paragraph HTML element for description in widget output

0.5

  • Improve error handling

0.4

  • Tested and verified for WordPress 3.6.1
  • Fixed a bug with capitalizing first char in tags

0.3

  • Widget can now be used on PHP 5.2 or greater.

0.2.1

  • Fixed a bug where deactivation removed settings.

0.2

  • Norwegian (Bokmål) translation.

0.1

  • Initial release.

Internationalization (i18n)

In addition to the default English language, translations in the following languages are included:

  • nb_NO - Norwegian (Bokmål)

If you're interested in doing a translation, please make a pull request on Github.

Share  
Download
Version 1.0.3

Requires WordPress version: 4.0 or higher

Compatible up to: 4.7.2

Last Updated 13 Feb 2017

Date Added: 04 Aug 2011

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

4.5 stars
2 ratings
2,149 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0