Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Log Deprecated Notices

Logs the usage of deprecated files, functions, and function arguments, and identifies where the deprecated functionality is being used.

This plugin logs the usage of deprecated files, functions, and function arguments. It identifies where the deprecated functionality is being used and offers the alternative if available.

This is a plugin for developers. WP_DEBUG is not needed, though its general usage is strongly recommended. Deprecated notices normally exposed by WP_DEBUG will be logged instead.

This plugin also logs incorrect function usage, which WordPress started reporting in 3.1.

Please report any bugs to plugins at andrewnacin.com, or find me in IRC #wordpress-dev or @nacin on Twitter.

This is young software. It works, but there's a lot left on the todo (check out the Other Notes tab). Have an idea? Let me know.

Author Andrew Nacin
Profile
Contributors nacin
Tags admin, deprecated, developer, E_NOTICE, logging, WP_DEBUG
  1. log-deprecated-notices screenshot 1

    Log screen.

For an automatic installation through WordPress:

  1. Go to the 'Add New' plugins screen in your WordPress admin area
  2. Search for 'Log Deprecated Notices'
  3. Click 'Install Now' and activate the plugin
  4. View the log in the 'Tools' menu, under 'Deprecated Calls'

For a manual installation via FTP:

  1. Upload the log-deprecated-notices directory to the /wp-content/plugins/ directory
  2. Activate the plugin through the 'Plugins' screen in your WordPress admin area

To upload the plugin through WordPress, instead of FTP:

  1. Upload the downloaded zip file on the 'Add New' plugins screen (see the 'Upload' tab) in your WordPress admin area and activate.

This plugin is will remove log entries when it is uninstalled and deleted.

Ideas

These are the various things on the @todo:

  • Plugin identification. Also, an unobstrusive note on plugins page next to said plugins.
  • Perhaps the ability to auto-purge the log.
  • Ability to filter on file or plugin in which the deprecated functionality is used.
  • Offer some kind of better multisite support.

Want to add something here? I'm all ears. plugins at andrewnacin.com or @nacin on Twitter.

I will prioritize these tasks based on feedback, so let me know what you'd like to see.

Share  
Download
Version 0.4

Requires WordPress version: 3.0 or higher

Compatible up to: 4.8-alpha

Last Updated 28 Jan 2017

Date Added: 27 Jun 2010

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

5 stars
8 ratings
71,106 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0