Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Lite Syntax Highlighting

Lite Syntax Highlighting: PHP, HTML, CSS, JS, C

The Plugin makes it easy to add syntax highlighting of code in your blog. You can use shortcodes in posts and comments and also html tags everywhere.

It adds some buttons to editor, which generate special short code tags to turn on syntax highlighting: [slh lang="php"] for example. And you can use html tags, example: <pre class="slh__html"></pre>

The plugin supports highlighting:

  • PHP
  • HTML
  • CSS
  • JavaScript
  • C

Languages:

  • English
  • Русский

Styles:

  • Light
  • Dark
Author Maksim Iliukovich
Profile
Contributors z-17
Tags code highlighter, highlighter, highlighting, syntax, syntax highlighter
  1. lite-syntax-highlighting screenshot 1

    Example for PHP code

  2. lite-syntax-highlighting screenshot 2

    Settings page

  3. lite-syntax-highlighting screenshot 3

    Editor

  4. lite-syntax-highlighting screenshot 4

    Dark style

  1. Upload the plugin files to the "/wp-content/plugins/" directory or install the plugin through the WordPress plugins screen directly..
  2. Activate the plugin through the "Plugins" menu in WordPress.
  3. Use the Settings -> Syntax Highlighting screen to configure the plugin

0.5

  • add support short codes
  • short codes also work in comments

0.4

  • add basic highlight for C language
  • some refactor

0.3

  • add dark style

0.2

  • Add languages support

0.1

  • Initial release.

What code is highlighted?

PHP, HTML, CSS, JavaScript and C

How can I help?

There are public repository: https://github.com/z17/Lite-Syntax-Highlighting Welcome!

How can I use it?

You can use special buttons in WordPress post editor, or use shortcodes like [slh lang="php"] to create block of code. Also you can just write html tags <pre class="slh__php"> CODE </pre> where you want.

How can I ask something?

Open new topic in support section or you can write me email, admin@blweb.ru

Share  
Download
Version 0.5

Requires WordPress version: 3.0 or higher

Compatible up to: 4.7.2

Last Updated 10 Dec 2016

Date Added: 04 Jan 2016

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

5 stars
2 ratings
490 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0