Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Frontend HTTP Auth Protection

Frontend HTTP Authentication Protection makes private front part of your website. When web developer like to give demo of website to end client before

Frontend HTTP Authentication Protection provides simple HTTP authentication layer to your fronend site. There is often need to prevent normal visitors and search engine from navigating front website, when website is in development environment before release website in production environment. This plugin serves this need very well by adding HTTP authentication layer to frontend site. This Wordpress Plugin uses HTTP Basic Authentication. This plugin is fully configurable from admin panel.

Author Prashant Baldha
Contributors pmbaldha
Tags Auth, frontend, http, protection, security
  1. frontend-http-authentication-protection screenshot 1

    Admin side configuration setting

  2. frontend-http-authentication-protection screenshot 2

    Frontend login prompt dialogue

  3. frontend-http-authentication-protection screenshot 3

    Frontend login prompt cancel error display

  1. Upload the entire frontend-http-auth-protection folder to the /wp-content/plugins/ directory.
  2. Activate the plugin through the \'Plugins\' menu in admin panel.
  3. Go to setting > Frontend HTTP Authentication for configuring setting and test functionality given by plugin.

0.1 Initial release

Is there any configuration require for this plugin?

Yes, You have to set username and password and other basic configurations.

What is default HTTP auth username and password when plugin will be activated ?

Default username is user and default password is user123

Can I set empty username and password when plugin will be activated ?

Yes, You can set blank value in empty and password.

Arbitrary section

Features: 1.Enable Disable Frontend HTTP Authentication 2.Set Custom Username and Password 3.Set Login Message which will display in login dialog prompt 4.Set error content by WYSWYG editor

Version 0.1

Requires WordPress version: 3.3.0 or higher

Compatible up to: 4.7.2

Last Updated 08 Dec 2016

Date Added: 01 Apr 2016

Plugin Homepage


5 stars
1 ratings


Not Enough Data

Works: 0
Broken: 0