Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Facebook Page Widget Slider

Facebbook Page Plugin allows to promote your facebook page under your website.

Placing a facebook widget like this on website is always been tricky and confusing. By using facebook page widget slider you can easily put your facebook plugin on your website and convert your website visits to revenue.

Facebook Page Widget Slider put a facebook icon on your website absolute left or right position. Using Facebook Page Widget Slider you can easily make sure the page attract your website visitors.

Just like on Facebook, your visitors can like and share the Page without having to leave your site.


Author Connex Studios
Tags Facebook, facebook likebox, Facebook Page, facebook page plugin, Facebook Page Widget Slider, facebook sidebar, facebook sidebar slider, facebook slider, facebook slider sidebar, Facebook Widget, page, page slider, shortcode, sidebar, slider, slideshow, widget, wordpress
  1. facebook-page-widget-slider screenshot 1

    Facebook Page Widget Slider

Install the Plugin - top

Login to your wordpress admin - example : go to "Plugins->Installed Plugins" from Menu Click "Add New" - button at top Click "Upload" - from the list Click "Choose File" - button a windows will open of your computer - browse file - select the package click "Install Now"

On successful completion of installation you will get a success massage.

Now you have to activate the plugin.

You are all set - Now if you go to your website homepage you probably will see the sidebar up with default options.

To customize the facebook page plugin you have to change the settings.

From Wordpress ADMIN area - go to -> Settings > Facebook Page Widget Slider

Edit the options available as your preferences. Once done close everything and see the plugin on your website.


Stable version release

It this plugin work for facebook profile or groups?

  • No it's not! Only work for facebook page.

How to create a facebook page?

Can I look at a demo of this plugin please?

Version 1.0

Requires WordPress version: 3.0.1 or higher

Compatible up to: 4.7.2

Last Updated 07 Feb 2017

Date Added: 24 Apr 2015

Plugin Homepage


0 stars
0 ratings


Not Enough Data

Works: 0
Broken: 0