Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

CiviCRM WordPress Profile Sync

CiviCRM WordPress Profile Sync keeps a WordPress and BuddyPress user profile in sync with a CiviCRM contact.

The CiviCRM WordPress Profile Sync plugin keeps the "First Name", "Last Name", "Email Address" and "Website" fields of a WordPress (and BuddyPress) user profile in sync with the corresponding fields of a CiviCRM contact. The synchronisation takes place regardless of whether the changes are made in WordPress, BuddyPress or CiviCRM.

Requirements

This plugin requires a minimum of WordPress 3.9 and CiviCRM 4.6-alpha1. It also requires BuddyPress 1.8 and the BP XProfile WordPress User Sync plugin for syncing data with BuddyPress profiles. Please refer to the installation page for how to use this plugin with versions of CiviCRM prior to 4.6-alpha1.

Plugin Development

This plugin is in active development. For feature requests and bug reports (or if you're a plugin author and want to contribute) please visit the plugin's GitHub repository.

Author Christian Wach
Profile
Contributors needle, cuny-academic-commons
Tags buddypress, civicrm, profile, sync, user, XProfile
  1. Extract the plugin archive
  2. Upload plugin files to your /wp-content/plugins/ directory
  3. Activate the plugin through the 'Plugins' menu in WordPress

For versions of CiviCRM prior to 4.6-alpha1, this plugin requires the corresponding branch of the CiviCRM WordPress plugin plus the custom WordPress.php hook file from the CiviCRM Hook Tester repo on GitHub so that it overrides the built-in CiviCRM file. Please refer to the each repo for further instructions.

0.2.4

  • Adds hooks before and after sync operations
  • Updates hook references for CiviCRM 4.7.x instances

0.2.3

Further fixes to bulk operations logic

0.2.2

Minor fixes to bulk operations logic

0.2.1

Initial WordPress plugin directory release

0.2

Added two-way Website sync Fixed unpredictable detection of sync direction

0.1

Initial release

Share  
Download
Version 0.2.5

Requires WordPress version: 3.9 or higher

Compatible up to: 4.6.3

Last Updated 14 Sep 2016

Date Added: 19 Jan 2015

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

0 stars
0 ratings
1,279 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0