Search Over 30,000 FREE Plugins from the Official WordPress Plugin Directory Repository

Child Theme Check

Warns you about outdated template files in your child theme and shows a diff view of the changes between parent and child theme template.

Child Themes are used to avoid overwriting your customizations. But if you preserve a file in a child theme, then you maybe preserve a security risk. After an update from the parent theme you always should check the changes and maybe add them to your child theme. This plugin helps you keeping track of these changes in the parent theme.

For full usage of the plugin your parent theme has to define the version of the template file in the header of the PHP file with an additional @version info.

For example: @version 1.0.0

If this is the case you will see a warning if the version of the parent theme file is higher than your child theme file. And you can see the differences between the parent theme file and the child theme file per wp_text_diff()-function like in revisions.

Some posts about this plugin:

These themes from Elmastudio are already using the @version info in the header:

  • Uku
  • Uku Light
  • Weta
  • Zeitreise
  • Werkstatt
  • Neubau
  • Hawea

Please spread the word and if you are a theme developer, please add this to your themes too! Thanks :)

Author Torsten Landsiedel
Profile
Contributors zodiac1978, drivingralle, fstaude, glueckpress, hinnerk, rkoller, presskopp
Tags check, child, child theme, child theme check, theme
  1. child-theme-check screenshot 1

    Status View

  2. child-theme-check screenshot 2

    Diff View

  1. Upload the zip file from this plugin on your plugins page or search for Child Theme Check and install it directly from the repository
  2. Activate the plugin through the 'Plugins' menu in WordPress
  3. Activate a child theme and run the child theme check from your tools menu

1.0.1

  • Fixed typo in German translation (Thanks @pixolin)
  • Changed text for action link on plugins page (Thanks @presskopp)
  • Tested up to 4.6.1

1.0.0

  • Initial release

I just get the error: Parent theme is missing version keyword.

For full usage of the plugin your parent theme has to define the version of the template file in the header of the PHP file with an additional @version info.

For example: @version 1.0.0

If this is the case you will see a warning if the version of the parent theme file is higher than your child theme file. And you can see the differences between the parent theme file and the child theme file per wp_text_diff()-function like in revisions.

Share  
Download
Version 1.0.1

Requires WordPress version: 3.4.0 or higher

Compatible up to: 4.6.3

Last Updated 24 Sep 2016

Date Added: 26 Sep 2015

Plugin Homepage

Evaluation
star1
star2
star3
star4
star5

5 stars
7 ratings
4,017 downloads

Compatibility

Not Enough Data

Reports:
Works: 0
Broken: 0